Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#75 closed defect (fixed)

Problem processing .svx files with aven

Reported by: Alan Gray Owned by: Olly Betts
Priority: major Milestone: 1.2.26
Component: aven Version: 1.2.24
Keywords: Cc:

Description

Hi

I have been successfully using Survex for many years – a fantastic piece of software.

After completing a partial re-survey of Upper Canada Cave (Mendip, UK) yesterday I created the text file as usual and renamed it with the .svx extension. I decided to see if there was an update of the Survex software and I updated from release 1.2.23 to 1.2.24. Right clicked in the Upper Canada Cave.svx file and the Aven screen was displayed with normal headings but with a white screen where the line survey should be. No Log File, 3D file or Error files were created.

I tried viewing one of my old 3D files in Aven (UCC.3D) and it worked perfectly; however when I tried to Process the old data file (UCC.svx) the same error occurred as detailed in the paragraph above.

I then removed Survex 1.2.24 from my computer and reinstalled 1.2.23 but the same error occurred as detailed in the paragraph above.

Please could you let me know how to fix this as I would dearly like to see the results of yesterdays survey. Something stupid that I have, or have not done I’m sure.

Many thanks

Alan Gray

Attachments (2)

Upper Canada Cave.svx (12.8 KB) - added by Alan Gray 4 years ago.
Upper Canada Cave .svx file
Screen Shot.doc (145.5 KB) - added by Alan Gray 4 years ago.
Aven screen shot

Download all attachments as: .zip

Change History (16)

comment:1 Changed 4 years ago by Olly Betts

Component: Otheraven
Milestone: 1.2.25
Priority: minormajor
Status: newassigned
Version: 1.2.24

Hmm, doesn't sound good.

I'm guessing you're running Microsoft Windows? If so, what version?

There was a change in 1.2.23 to process .svx files with aven by default. This uncovered some bugs in that support, which should be fixed in 1.2.24, and we did test that, but it sounds like there are still issues.

So aven opening like that is expected, but the log from processing the data should be appearing in the white window.

If you open aven first, then use "File->Open" and point it at UCC.svx, does that work any better?

If you want to downgrade for now, you'll probably need to go back to 1.2.22. I'm not sure why 1.2.23 was installed and working for you - possibly 1.2.23's installer didn't update the file associations if they were already set, but 1.2.24's might (the installer code had a major overhaul for 1.2.24). If reverting to 1.2.22 works, doing that and then upgrading to 1.2.23 might work (since it sounds like it did before).

If you're comfortable with using a command line, you could also stay with 1.2.24 but run cavern from the command line until we get this fixed.

comment:2 Changed 4 years ago by Olly Betts

1.2.24's aven seems to work OK on MS Windows 7 - right-click on .svx file, select Process, and the file is processed and loaded into aven. Or if the .svx file has an error, aven shows the log window with cavern's output.

So I guess this is specific to a newer OS version.

comment:3 Changed 4 years ago by Olly Betts

The sysadmin of the machine hosting trac.survex.com forwarded me this email response (please don't reply to the notification emails, instead follow the link and reply in trac):

Hi Olly Thanks for the very prompt reply. I am running Windows 7 Professional. I removed 1.2.24 and installed 1.2.22 which worked fine. I then installed 1.2.23 over 1.2.22 and 1.2.23 did not work same error as reported in the first e-mail. I removed 1.2.23 and installed 1.2.22 which worked fine. Thanks again Alan Gray

OK, same OS version then, so it's not just down to that.

Did you try this suggestion with 1.2.24:

If you open aven first, then use "File->Open" and point it at UCC.svx, does that work any better?

comment:4 Changed 4 years ago by Alan Gray

Hi Olly

Thanks for the reply.

Tried you suggestion with 1.2.24 - If you open aven first, then use "File->Open" and point it at UCC.svx and it did not work - same error as before also no log file generated.

Now processed and generated the survey for the re-survey of Upper Canada Cave using 1.2.22 worked perfectly.

Many thanks

Alan Gray

comment:5 Changed 4 years ago by Olly Betts

I suspect the issue here is probably that the full filename contains a space. If you copy the file to (say) C:\UCC.svx can you process it from there?

If that's the issue, it's actually already fixed in the code under development (but didn't work correctly in all cases in the last release).

comment:6 Changed 4 years ago by Olly Betts

I decided to just make a release, as it has been a few months since the last one and a number of useful changes have accumulated.

Please retest with 1.2.25, and if it still fails attach a screenshot and let me know the full filename of the problematic file.

Changed 4 years ago by Alan Gray

Attachment: Upper Canada Cave.svx added

Upper Canada Cave .svx file

Changed 4 years ago by Alan Gray

Attachment: Screen Shot.doc added

Aven screen shot

comment:7 Changed 4 years ago by Alan Gray

Hi Olly

Thanks for all your help.

  1. Used Control Panel to delete -22
  1. Installed -25
  1. Process Upper Canada Cave.svx (Note this worked using -22 and this file name).
  1. Aven Error screen - Could not run external command C:Program Files(x86)\Survex\cavern D:\users\Alan Gray\Desktop\New folder\Upper Canada Cave.svx (No error)
  1. Click on OK in error box and the Aven screen is shown with the blue rotating circle indicating that the programme is waiting or is in a loop.
  1. I closed the Programme after five minutes.
  1. Then used another Survex file Ravens Well.svx
  1. Re-named it to RW.svx
  1. Tried to process it - same error
  1. Uninsalled -25
  1. Re-installed -22 works fine.

I have attached the screen shot and Upper Canada Cave.svx

Many thanks

Alan Gray

comment:8 Changed 4 years ago by Olly Betts

Thanks for the screenshot - unfortunately it's been scaled down and so I can't actually read the text in it. It looks like some quoting is happening, but I can't make out what exactly and the details are what matter in these things.

You can probably avoid that if you screenshot just the popup - make sure it has focus, and then Alt+PrintScreen should work.

comment:9 Changed 4 years ago by Olly Betts

Never mind, I can reproduce this under wine (turns out I have two installs of Survex there, and I tested the wrong one, not the 1.2.25 candidate I thought I was).

comment:10 Changed 4 years ago by Olly Betts

OK, could you try this build:

http://survex.com/software/test/survex-win32-1.2.25a.exe

It works OK in my testing so far...

comment:11 Changed 4 years ago by Alan Gray

Hi Olly

Processed Upper Canada Cave.svx (the copy I sent to you) and Raven's Well.svx (Surveyed in 2012) both processed fine and the Err and 3D files were generated but not the Log file in each case.

Thanks for your help.

Alan Gray

comment:12 Changed 4 years ago by Olly Betts

Resolution: fixed
Status: assignedclosed

Great.

The log file isn't generated by default when processing through aven, which makes the behaviour consistent with other platforms, and means you don't end up with a lot of log files cluttering up your disk. If you want a copy of the log in a file there's a "Save Log" button on the log page in aven - you can get to this via "File->Show Log" or the "piece of paper" icon near the left end of the toolbar.

Last edited 4 years ago by Olly Betts (previous) (diff)

comment:13 Changed 4 years ago by Alan Gray

Hi Olly

Works just perfectly - many thanks for all your help - more surveying to do on Saturday.

Alan Gray

comment:14 Changed 4 years ago by Olly Betts

Summary: Survex ProblemProblem processing .svx files with aven
Note: See TracTickets for help on using tickets.