Opened 4 years ago

Closed 4 years ago

#73 closed defect (fixed)

Displaying LRUDs for vertical legs

Reported by: Erin Lynch Owned by: Olly Betts
Priority: minor Milestone: 1.2.25
Component: aven Version: 1.2.24
Keywords: Cc:

Description

There is a bug in the way LRUDs are displayed for stations connected by a vertical leg. The example below should produce a tube which is 10m tall and 10m wide, but in aven the passage at stations 1 and 2 is 20m tall with an abrupt step.

*data normal from to tape compass clino 0 1 20 0 0 1 2 10 - UP 2 3 20 0 0

*data passage station left right up down 0 5 5 10 0 1 5 5 10 0 2 5 5 0 10 3 5 5 0 10

Change History (1)

comment:1 Changed 4 years ago by Olly Betts

Milestone: 1.2.25
Resolution: fixed
Status: newclosed
Version: 1.2.24

Reproduced with 1.2.24.

This is caused by a bit of special case code for handling the transition to/from a vertical leg - this is meant to extend the ceiling/floor out over/under the pitch a bit, so that pitches don't just become a 2D vertical sheet. The applied offset ought to be horizontal (or perhaps angled with the non-vertical leg) but it's actually vertical so it just produces the odd effect your example demonstrates, and doesn't actually help.

I've just had a quick go at fixing this, but the obvious change leads to a "Z" shape tube for a simple horizontal leg, vertical leg, horizontal leg example (such as yours if the pitch is made deeper).

I think the sensible answer for now is just to remove that code, which I've done in [be566f2742abcfa36a84337d07d5458aa31ad631/git] and that fixes the reported bug. I've opened #76 for the pitch flattening issue.

Note: See TracTickets for help on using tickets.