Opened 12 years ago

Closed 5 years ago

#2 closed defect (fixed)

netbits.c:1074: covariance matrix is singular

Reported by: susscorfa Owned by: Olly Betts
Priority: major Milestone: 1.2.18
Component: cavern Version: 1.2.17
Keywords: Cc:

Description

When i run the all.svx file i get this error

"netbits.c:1074: covariance matrix is singular"

I have no clue where the problem is

Attachments (7)

all.svx (1.1 KB) - added by trac 6 years ago.
intended.svx (1.0 KB) - added by trac 6 years ago.
measured.svx (472 bytes) - added by trac 6 years ago.
plot_layout.svx (932 bytes) - added by trac 6 years ago.
realized.svx (1.2 KB) - added by trac 6 years ago.
yavitt.svx (182 bytes) - added by trac 6 years ago.
ticket2min.svx (118 bytes) - added by Olly Betts 5 years ago.
Minimal reproducer

Download all attachments as: .zip

Change History (12)

comment:2 Changed 11 years ago by Olly Betts

Component: component1cavern
Owner: changed from somebody to Olly Betts
Status: newassigned

Which version is this in?

Changed 6 years ago by trac

Attachment: all.svx added

Changed 6 years ago by trac

Attachment: intended.svx added

Changed 6 years ago by trac

Attachment: measured.svx added

Changed 6 years ago by trac

Attachment: plot_layout.svx added

Changed 6 years ago by trac

Attachment: realized.svx added

Changed 6 years ago by trac

Attachment: yavitt.svx added

comment:3 Changed 6 years ago by Olly Betts

While upgrading trac, it warned me there were attachments for this ticket on disk but not registered in the database, so I fished them out and actually attached them.

Changed 5 years ago by Olly Betts

Attachment: ticket2min.svx added

Minimal reproducer

comment:4 Changed 5 years ago by Olly Betts

Version: 1.2.17

OK, I can reproduce with 1.2.17, despite there being an included file missing from the attachments.

I've distilled the example down to a single 7 line file, which I've attached.

I haven't dug in yet, but I suspect the problem is due to the 0 vertical SD on the *fix commands. If you set this to a small value (for example, 0.001 metres) then it works.

It's probably unrealistic to claim the fixed points are accurate to better than 1mm, but specifying a 0 SD should either work or explicitly not be supported and give an error (or maybe a warning and get set to something small instead).

comment:5 Changed 5 years ago by Olly Betts

Milestone: 1.2.18

Set milestone - we should try to address this in 1.2.18.

comment:6 Changed 5 years ago by Olly Betts

Resolution: fixed
Status: assignedclosed

Added a check that the SDs are positive in [2cfcb322471e76a93374e79c386b95460ac36d21/git].

Note: See TracTickets for help on using tickets.