Opened 9 years ago

Closed 6 years ago

#24 closed defect (fixed)

Gnome print preview window opens underneath aven window

Reported by: Olly Betts Owned by: Olly Betts
Priority: minor Milestone:
Component: aven Version: 1.2.0
Keywords: Cc:

Description

If you print (Ctrl+P) and print button then preview, the print preview window always seems to open under the aven window, which isn't ideal.

This is with Debian stable and trunk between Survex 1.2.0 and 1.2.1.

This window is opened by wx or gnome libraries though, so it's not at all clear what we can do about it. It's not clear where the issue is, which makes it harder to fix and send a patch upstream.

Perhaps newer wx fixes this - that's a good thing to try first.

Change History (3)

comment:1 Changed 9 years ago by Olly Betts

Milestone: 1.2.2

comment:2 Changed 9 years ago by Olly Betts

Milestone: 1.2.2

Still seems to open underneath with 2.8.12, which is the most recent 2.8 release currently.

However, gnomeprint seems to be on the way out so I'm not sure if this is likely to get fixed sadly.

comment:3 Changed 6 years ago by Olly Betts

Resolution: fixed
Status: newclosed

Now gnomeprint has gone from debian, and probably everywhere else too. The isn't a print preview when built with wx2.8 now, and this problem doesn't occur with wx 3.0, so closing.

Note: See TracTickets for help on using tickets.