Opened 9 years ago

Closed 8 years ago

#12 closed defect (worksforme)

Aven displays log very slowly when processing .svx file

Reported by: Duncan Collis Owned by: Olly Betts
Priority: major Milestone: 1.1.15
Component: aven Version: 1.1.13
Keywords: Cc:

Description

The log file is displayed incredibly slowly when Aven causes a .svx file to be processed; for example in one case a file which takes 0.07s to process (according to the log) takes around 12s for the log to be displayed; the text appears slowly line-by-line.

Change History (9)

comment:1 Changed 9 years ago by Olly Betts

I guess from your comment on #11 that this issue is on Ubuntu?

What version of wxWidgets is this with (see "Help->About")?

comment:2 Changed 9 years ago by Duncan Collis

Yes, Ubuntu 10.04.

Linux 2.6.32-23-generic i686

wxWidgets 2.8.10 (GTK+ >= 2.6)

comment:3 Changed 9 years ago by Olly Betts

Status: newassigned

I don't see this myself, but I suspect the issue is with calling wxYield a lot - it happens when we're waiting for cavern to produce output, and after each line so we get the output window updated. In r3479 I've increased the time we wait for output before calling wxYield (from 0.00001s to 0.1s) and changed it to call Update() instead of wxYield() to get the window updated after each line, which I think will solve your issue.

So I hope this will be fixed in the next release, but if you want to test this sooner that would be useful - to do that download this patch:

http://trac.survex.com/changeset/3479/trunk/src/cavernlog.cc?format=diff&new=3479

And apply to your source tree by running this from a terminal with the current directory as the top level of the unpacked Survex tree:

patch -p1 < changeset_trunk_src_cavernlog.cc_r3479.diff
make

comment:4 Changed 9 years ago by Olly Betts

Could you check if this is fixed by 1.1.14?

comment:5 Changed 9 years ago by Duncan Collis

The problem remains in 1.1.14

comment:6 Changed 9 years ago by Olly Betts

Milestone: 1.1.15

OK, hopefully r3542 addresses this. The forthcoming 1.1.15 release will include that change.

comment:7 Changed 8 years ago by Olly Betts

Did 1.1.15 fix this?

comment:8 Changed 8 years ago by Olly Betts

Hi, are you still seeing this issue with 1.1.15 or 1.1.16?

comment:9 Changed 8 years ago by Olly Betts

Resolution: worksforme
Status: assignedclosed

Well, this works for me and there's been no feedback in 5 months, so closing. If you're still seeing this issue with a recent release, please reopen.

Note: See TracTickets for help on using tickets.