Opened 4 months ago

Closed 4 months ago

#104 closed defect (duplicate)

Fails to build with proj-6.1.0: ld: error: undefined symbol: pj_factors

Reported by: yurivict Owned by: Olly Betts
Priority: minor Milestone:
Component: Other Version:
Keywords: Cc:

Description

I am trying to build the survex FreeBSD port with proj-6.1.0.

First, it asked to add -DACCEPT_USE_OF_DEPRECATED_PROJ_API_H. With this define the build proceeds, but later fails: cc -Wall -W -Wunused -Wshadow -Wpointer-arith -Wmissing-prototypes -Wwrite-strings -Wredundant-decls -Wnested-externs -Wcast-align -I/usr/local/include -O2 -pipe -fno-omit-frame-pointer -DACCEPT_USE_OF_DEPRECATED_PROJ_API_H -fstack-protector-strong -fno-strict-aliasing -I/usr/local/include -fstack-protector-strong -o cavern cavern.o date.o listpos.o commands.o datain.o netskel.o network.o readval.o matrix.o img_hosted.o netbits.o useful.o validate.o netartic.o thgeomag.o cmdline.o message.o str.o filename.o osdepend.o z_getopt.o getopt1.o -L/usr/local/lib -lproj -lm ld: error: undefined symbol: pj_factors

referenced by commands.c

commands.o:(cmd_declination)

cc: error: linker command failed with exit code 1 (use -v to see invocation)

FreeBSD 12 clang-8

Change History (1)

comment:1 Changed 4 months ago by Olly Betts

Resolution: duplicate
Status: newclosed

Thanks for the report.

It's a known issue, but unfortunately we don't have a solution currently (apart from use an older version of PROJ):

https://trac.survex.com/ticket/102#comment:2

Closing as a duplicate of #102.

Note: See TracTickets for help on using tickets.