Opened 6 months ago

Closed 5 months ago

#103 closed defect (duplicate)

Build issue

Reported by: Richard Knapp Owned by: Olly Betts
Priority: blocker Milestone:
Component: Other Version: 1.2.36
Keywords: Mac Home Brew Cc:

Description

I was trying to build latest version 1.2.38 (cannot specify on this page for 1.2.38) on Mac OSX 10.13.6 and almost finished. Att the end I received a couple errors about a missing macro. Here is the end of the build log file:

In file included from ./cavern.h:36: /usr/local/Cellar/proj/6.1.0/include/proj_api.h:37:2: error: 'To use the proj_api.h you must define the macro ACCEPT_USE_OF_DEPRECATED_PROJ_API_H' #error 'To use the proj_api.h you must define the macro ACCEPT_USE_OF_DEPRECATED_PROJ_API_H'

1 error generated. 2 errors generated. make[3]: * [listpos.o] Error 1 make[3]: * Waiting for unfinished jobs.... make[3]: * [cavern.o] Error 1 2 errors generated. make[3]: * [commands.o] Error 1 mv -f .deps/date.Tpo .deps/date.Po make[2]: * [all] Error 2 make[1]: * [all-recursive] Error 1 make: * [all] Error 2

Change History (1)

comment:1 Changed 5 months ago by Olly Betts

Resolution: duplicate
Status: newclosed

Thanks for your report.

Unfortunately we don't currently support PROJ 6.1.0 (which is already tracked in #102). The next release should at least work with PROJ 5.x though.

Closing as a duplicate of #102.

Note: See TracTickets for help on using tickets.