Opened 5 years ago

Closed 5 years ago

#78 closed defect (fixed)

CLINO and BACKCLINO readings must be of the same type for DOWN/DOWN, corrected backsights

Reported by: Andy Edwards Owned by: Olly Betts
Priority: minor Milestone: 1.2.25
Component: cavern Version: 1.2.15
Keywords: clino backclino down Cc:

Description

Here's an except of my data:

*begin ; 111: <REDACTED>
*date 1983.07.13

*team <REDACTED>
*team <REDACTED>
*units tape feet
*calibrate BACKCOMPASS 180.00
*calibrate BACKCLINO 0.00 -1.00

*data normal from to tape compass backcompass clino backclino
;From       To          Distance    Compass     BackCompass Clino       BackClino  
<...REDACTED>
HC14        HC15        10.7        296         296         -26         -26               
HC15        HC16        1.3         -           -           DOWN        DOWN      

Cavern complains that "CLINO and BACKCLINO readings must be of the same type" for the DOWN/DOWN line, but not the -26/-26 line.

Is this invalid Survex data or is it a bug in Cavern?

Change History (3)

comment:1 Changed 5 years ago by Olly Betts

The error message could be clearer (it's written for the case where you have a clino reading one way and a plumb the other), but it's actually complaining about DOWN vs DOWN - the clino correction doesn't apply to plumbs (because you don't measure a plumb using the clino), so you need one UP and one DOWN there, even though you've flipped the backclino reading 180 degrees.

It appears your "backsight" is actually a second forward sight, so you might be better off just making use of the averaging of repeated versions of a leg (a feature added in 1.2.17), especially if you're actually remeasuring the distance each time (as you would be if you just measure the leg twice with a disto-x or similar device) - e.g. this is two legs, each read twice (you need to have the multiple versions of the leg together for this to work):

HC14        HC15        10.7        296         -26
HC14        HC15        10.7        296         -26
HC15        HC16        1.3         -           DOWN      
HC15        HC16        1.3         -           DOWN      

This gives:

Survey contains 3 survey stations, joined by 2 legs.
There are 0 loops.
Total length of survey legs =   12.00m (  12.00m adjusted)
Total plan length of survey legs =    9.62m
Total vertical length of survey legs =    5.99m

Is this invalid Survex data or is it a bug in Cavern?

It's certainly invalid Survex data as things stand. It's not a bug in cavern, but perhaps a missing feature - if you're only measuring the distance once, it's not really right to repeat the leg - really you want to be able to repeat readings individually.

What's the actual surveying method you're trying to represent here?

comment:2 Changed 5 years ago by Andy Edwards

Thanks for clarifying this! The shot was definitely a plumb shot that had an (unnecessary) backsight in the source data, so we should probably just omit the backsight when we generate the survex data.

comment:3 Changed 5 years ago by Olly Betts

Milestone: 1.2.25
Resolution: fixed
Status: newclosed

I've improved the error message for this case in [5d1c60c32e5903701d5200456ae4d923f7430dfa/git] - it's now:

Plumbed CLINO and BACKCLINO readings can't be in the same direction

Backsighting a plumb doesn't conceptually entirely make sense (you can't really measure the plumb in both directions, and even if you could, it's either "UP" or "DOWN", so the readings can't be averaged), but I can see some people perhaps might not want to omit the reading. But if you're generating the .svx file, you easily can.

I think there's nothing else to do here, so closing. The improved message will be in 1.2.25.

Note: See TracTickets for help on using tickets.