Opened 5 years ago

Closed 4 years ago

Last modified 4 years ago

#47 closed defect (fixed)

[Mac] Clicking on station randomly changes the view

Reported by: Hugh St.Lawrence Owned by: Olly Betts
Priority: major Milestone: 1.2.19
Component: aven Version: 1.2.17
Keywords: log file Cc:

Description

comments on Mac version...

  • processing a .svx file does not produce a log file - so unable to get length/depth details of survey
  • clicking on a station in Aven view most times resets the view to some random angle or size/magnification....sometimes flipping the survey 180º !

Change History (4)

comment:1 Changed 5 years ago by Olly Betts

Component: Otheraven

Not being able to view the log easily when you process survey data through aven is a known omission - I just haven't got to it before now.

I'm trying to move away from processing a dataset generating more than one file on disk, as it just tends to lead to a mess of files.

I've addressed the first point in commit [d7b53e3fdb775127d72b07433d600189a4c21bec] - if you process a .svx file with aven, you can now view the log by using "File->Show Log" or clicking on the "log" icon on the toolbar.

And commit [0e81a880c72a67665c7c025808752ef9a9f493a8] adds a button so you can save that log to a file should you really want to.

Both those fixes will be in the next release (1.2.18).


I didn't see the issue you describe with clicking on a station when I tested the Mac build, but I no longer have ready access to a Mac to try to reproduce it. So you'll need to help me work out what's going on.

A click on a station should just centre the view on that station, and the code for handling this is the same for all platforms. That makes me suspect it's an issue with the input which the aven code receives - perhaps a bug in wxWidgets, but I'm wondering if the problem could be that your click is getting interpreted as a "gesture" by OS X. If you disable mouse/trackpad gestures, do you still see the effect?

Last edited 5 years ago by Olly Betts (previous) (diff)

comment:2 Changed 5 years ago by Olly Betts

Summary: v. 1.2.17 Mac[Mac] Clicking on station randomly changes the view

Hugh replied to the notification email, which doesn't work, but the sysadmin noticed and forwarded me the mail:


Look forward to 1.2.18 and the log file fixes! Thx. Re. the screen view - attached are two files, aven1 and aven2. aven1 shows the bit of survey I am looking at with a station highlighted (top rightish) but not yet clicked. aven2 shows the view after the station has been clicked. You see how it's been spun round. Sometimes other effects may be apparent on clicking - like a zoom out as well as a spin. It's all rather random. But you never get a straight centreing of the chosen station in the same scale and orientation, as you do on a PC. There are no such things as mouse/trackpad gestures in Mac preferences, so I can't disable them!

comment:3 Changed 4 years ago by Olly Betts

I saw such preferences on the Mac I built the last release on, and this suggests I wasn't hallucinating:

http://applesliced.com/ask/how-do-i-turn-off-multi-touch-gestures-in-os-x-lion

What OS X version are you using? Perhaps they've been added more recently.

comment:4 Changed 4 years ago by Olly Betts

Milestone: 1.2.19
Resolution: fixed
Status: newclosed

OK, I managed to borrow a Mac for a few days, and can reproduce this. Fixed in [655aa2c27d72d76515524b2a2e6878d54f92eb32/git].

The issue is that on OS X, when we centre the view on the station this can generate a mouse move event. The solution is simply to clear the variable which says we are dragging before we process a left click on a station, so that this mouse move doesn't get interpreted as a drag.

Last edited 4 years ago by Olly Betts (previous) (diff)
Note: See TracTickets for help on using tickets.