Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#20 closed defect (fixed)

Aven crashes on opening file on Ubuntu 11.04

Reported by: Mike Owned by: Olly Betts
Priority: blocker Milestone: 1.2.0
Component: aven Version: 1.1.16
Keywords: Cc:

Description (last modified by Olly Betts)

Opening a 3d file results in the following:-

The program 'aven' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadDrawable (invalid Pixmap or Window parameter)'.
  (Details: serial 33805 error_code 9 request_code 137 minor_code 8)

Help About... shows:-

Linux 2.6.38-11-generic i686
wxWidgets 2.8.11 (GTK+ >= 2.6)
Display Depth: 24 bpp (colour)
No OpenGL information available yet - try opening a file.

Graphics card is Radeon X1300/X1550 Series

Failure seems to leave the following message in Xorg.0.log:

[273047.328] (EE) RADEON(0): [DRI2] DRI2SwapBuffers: drawable has no back or front?

Change History (6)

comment:1 Changed 8 years ago by Olly Betts

Description: modified (diff)

Hmm, a nice catch-22 there - you can't get the OpenGL info because opening a file is what causes the crash.

Is this with the package from the PPA or a version you built yourself?

comment:2 in reply to:  1 Changed 8 years ago by Mike

Replying to olly:

Hmm, a nice catch-22 there - you can't get the OpenGL info because opening a file is what causes the crash.

Is this with the package from the PPA or a version you built yourself?

This is with the 1.1.16 package on Wookey's PPA but also happens with the 1.1.14 on Ubuntu Software Centre

comment:3 Changed 8 years ago by Olly Betts

Owner: changed from Olly to Olly Betts
Status: newassigned

Stuart Bennett reported a similar issue with a fix to the list, and I've committed something along those lines in r3623. If you can easily try that patch, it would be useful to know if this also fixes your similar symptoms. If it's not easy, just let us know how the next release does.

comment:4 in reply to:  3 Changed 8 years ago by Mike

Replying to olly:

Stuart Bennett reported a similar issue with a fix to the list, and I've committed something along those lines in r3623. If you can easily try that patch, it would be useful to know if this also fixes your similar symptoms. If it's not easy, just let us know how the next release does.

I'm currently in France with only a Windows laptop so can't test this until I get home next week. I've read Stuart's e-mails with interest and am very hopeful this will fix it.

comment:5 Changed 8 years ago by Mike

Resolution: fixed
Status: assignedclosed

I've now built version 1.2.0 from source on Ubuntu 11.04 and confirm that the problem is fixed.

comment:6 Changed 8 years ago by Olly Betts

Milestone: 1.2.0

Thanks for testing.

Setting the milestone to mark where this was fixed.

Note: See TracTickets for help on using tickets.