Opened 10 months ago

Closed 4 months ago

Last modified 3 months ago

#123 closed defect (fixed)

brew upgrade / reinstall survex fail

Reported by: Enrico Fratnik Owned by: Olly Betts
Priority: blocker Milestone:
Component: Other Version: 1.2.43
Keywords: Cc:

Description (last modified by Olly Betts)

Dear all,

when I brew upgrade my system or try to reinstall survex brew report an error (see below).

Any idea?

Thank you in advance

enrico

@icts-enrico ~ % brew tap survex/survex https://git.survex.com/homebrew-survex

@icts-enrico ~ % brew reinstall survex
==> Downloading https://survex.com/software/1.2.43/survex-1.2.43.tar.gz
######################################################################## 100.0%
==> Reinstalling survex/survex/survex 
==> ./configure --prefix=/usr/local/Cellar/survex/1.2.43 --bindir=/usr/local/Cellar/survex/1.2.43/bin --mandir=/usr/local/Cellar/sur
==> make
Last 15 lines from /Users/enricof/Library/Logs/Homebrew/survex/02.make:
1 error generated.
1 error generated.
1 errormake[3]:  generated.
*** [readval.o] Error 1
make[3]: *** [cavern.o] Error 1
make[3]: *** [network.o] Error 1
make[3]: *** [netskel.o] Error 1
1 error generated.
make[3]: *** [commands.o] Error 1
1 error generated.
make[3]: *** [datain.o] Error 1
mv -f .deps/date.Tpo .deps/date.Po
make[2]: *** [all] Error 2
make[1]: *** [all-recursive] Error 1
make: *** [all] Error 2

If reporting this issue please do so to (not Homebrew/brew or Homebrew/core):
  survex/survex

Traceback (most recent call last):
	26: from /usr/local/Homebrew/Library/Homebrew/build.rb:229:in `<main>'
	25: from /usr/local/Homebrew/Library/Homebrew/build.rb:133:in `install'
	24: from /usr/local/Homebrew/Library/Homebrew/utils.rb:550:in `with_env'
	23: from /usr/local/Homebrew/Library/Homebrew/build.rb:138:in `block in install'
	22: from /usr/local/Homebrew/Library/Homebrew/formula.rb:1275:in `brew'
	21: from /usr/local/Homebrew/Library/Homebrew/formula.rb:2401:in `stage'
	20: from /System/Library/Frameworks/Ruby.framework/Versions/2.6/usr/lib/ruby/2.6.0/forwardable.rb:230:in `stage'
	19: from /usr/local/Homebrew/Library/Homebrew/resource.rb:91:in `stage'
	18: from /usr/local/Homebrew/Library/Homebrew/resource.rb:116:in `unpack'
	17: from /usr/local/Homebrew/Library/Homebrew/resource.rb:199:in `mktemp'
	16: from /usr/local/Homebrew/Library/Homebrew/mktemp.rb:63:in `run'
	15: from /usr/local/Homebrew/Library/Homebrew/mktemp.rb:63:in `chdir'
	14: from /usr/local/Homebrew/Library/Homebrew/mktemp.rb:63:in `block in run'
	13: from /usr/local/Homebrew/Library/Homebrew/resource.rb:117:in `block in unpack'
	12: from /usr/local/Homebrew/Library/Homebrew/download_strategy.rb:102:in `stage'
	11: from /usr/local/Homebrew/Library/Homebrew/download_strategy.rb:115:in `chdir'
	10: from /usr/local/Homebrew/Library/Homebrew/download_strategy.rb:115:in `chdir'
	 9: from /usr/local/Homebrew/Library/Homebrew/resource.rb:121:in `block (2 levels) in unpack'
	 8: from /usr/local/Homebrew/Library/Homebrew/formula.rb:2421:in `block in stage'
	 7: from /usr/local/Homebrew/Library/Homebrew/utils.rb:550:in `with_env'
	 6: from /usr/local/Homebrew/Library/Homebrew/formula.rb:2422:in `block (2 levels) in stage'
	 5: from /usr/local/Homebrew/Library/Homebrew/formula.rb:1282:in `block in brew'
	 4: from /usr/local/Homebrew/Library/Homebrew/build.rb:178:in `block (2 levels) in install'
	 3: from /usr/local/Homebrew/Library/Taps/survex/homebrew-survex/HomebrewFormula/survex.rb:21:in `install'
	 2: from /usr/local/Homebrew/Library/Homebrew/formula.rb:2192:in `system'
	 1: from /usr/local/Homebrew/Library/Homebrew/formula.rb:2192:in `open'
/usr/local/Homebrew/Library/Homebrew/formula.rb:2256:in `block in system': Failed executing: make (BuildError)
	9: from /usr/local/Homebrew/Library/Homebrew/brew.rb:164:in `<main>'
	8: from /usr/local/Homebrew/Library/Homebrew/brew.rb:176:in `rescue in <main>'
	7: from /usr/local/Homebrew/Library/Homebrew/exceptions.rb:509:in `dump'
	6: from /usr/local/Homebrew/Library/Homebrew/exceptions.rb:455:in `issues'
	5: from /usr/local/Homebrew/Library/Homebrew/exceptions.rb:459:in `fetch_issues'
	4: from /usr/local/Homebrew/Library/Homebrew/utils/github.rb:61:in `issues_for_formula'
	3: from /usr/local/Homebrew/Library/Homebrew/utils/github.rb:30:in `search_issues'
	2: from /usr/local/Homebrew/Library/Homebrew/utils/github.rb:160:in `search'
	1: from /usr/local/Homebrew/Library/Homebrew/utils/github/api.rb:234:in `open_rest'
/usr/local/Homebrew/Library/Homebrew/utils/github/api.rb:304:in `raise_error': Validation Failed: [{"message"=>"The listed users and repositories cannot be searched either because the resources do not exist or you do not have permission to view them.", "resource"=>"Search", "field"=>"q", "code"=>"invalid"}] (GitHub::API::ValidationFailedError)

Change History (7)

comment:1 Changed 4 months ago by Pawczak

Hey! I got similar error while trying to Install Survex on MacOS Monterey Version: 12.1 (21C52).

I won't paste the logs from brew installation because error is the same.

Is there any other installation options ?

comment:2 Changed 4 months ago by Olly Betts

Description: modified (diff)
Resolution: fixed
Status: newclosed

I was hoping someone who actually uses macos would address this, but given nobody has I've had a go myself.

It's hard to be sure because only the end of the log is shown (whereas typically it's the first errors that are the most interesting) but my guess was that this is a proj version issue, so I've updated the homebrew repo to Survex 1.4.1 which works with newer proj versions.

I have also managed to set up test installing via continuous integration so this new package should install on both macos 10.15 and 11:

https://github.com/ojwb/homebrew-survex/actions/runs/1781622178

I'll close as this should be resolved - if it isn't for you please reopen (or comment if you can't and I'll reopen) with details.

comment:3 Changed 4 months ago by Pawczak

Resolution: fixed
Status: closedreopened

Hey, the same error when trying to install by homebrew.

I follow installation steps which are on the site so in console i write:

brew tap survex/survex https://git.survex.com/homebrew-survex
brew install survex

MacOS Monterey 12.1 (21C52)

Installation logs:

pawczak@Pawes-MacBook-Pro ~ % brew install survex
Running `brew update --preinstall`...
==> Auto-updated Homebrew!
Updated 2 taps (homebrew/core and homebrew/cask).
==> Updated Formulae
Updated 41 formulae.
==> New Casks
polypane
==> Updated Casks
Updated 37 casks.

Warning: Use wxwidgets instead of deprecated wxmac
Warning: Use wxwidgets instead of deprecated wxmac
Warning: Use wxwidgets instead of deprecated wxmac
Warning: Use wxwidgets instead of deprecated wxmac
Warning: Use wxwidgets instead of deprecated wxmac
Warning: Use wxwidgets instead of deprecated wxmac
Warning: Use wxwidgets instead of deprecated wxmac
Warning: Use wxwidgets instead of deprecated wxmac
Warning: Use wxwidgets instead of deprecated wxmac
Warning: Use wxwidgets instead of deprecated wxmac
==> Downloading https://ghcr.io/v2/homebrew/core/harfbuzz/manifests/3.3.1
######################################################################## 100.0%
==> Downloading https://ghcr.io/v2/homebrew/core/harfbuzz/blobs/sha256:e72b14589
==> Downloading from https://pkg-containers.githubusercontent.com/ghcr1/blobs/sh
######################################################################## 100.0%
==> Downloading https://survex.com/software/1.2.43/survex-1.2.43.tar.gz
Already downloaded: /Users/pawczak/Library/Caches/Homebrew/downloads/d1de25d72a83c9ff2e9251d42c8a490fe2d26011a71f3754ed7af4f8a062313f--survex-1.2.43.tar.gz
==> Installing survex from survex/survex
Warning: Use wxwidgets instead of deprecated wxmac
Warning: Use wxwidgets instead of deprecated wxmac
Warning: Use wxwidgets instead of deprecated wxmac
Warning: Use wxwidgets instead of deprecated wxmac
Warning: Use wxwidgets instead of deprecated wxmac
Warning: Use wxwidgets instead of deprecated wxmac
==> Installing dependencies for survex/survex/survex: harfbuzz
==> Installing survex/survex/survex dependency: harfbuzz
==> Pouring harfbuzz--3.3.1.arm64_monterey.bottle.tar.gz
🍺  /opt/homebrew/Cellar/harfbuzz/3.3.1: 68 files, 7.2MB
==> Installing survex/survex/survex
Warning: Use wxwidgets instead of deprecated wxmac
Warning: Use wxwidgets instead of deprecated wxmac
Warning: Use wxwidgets instead of deprecated wxmac
Warning: Use wxwidgets instead of deprecated wxmac
Warning: Use wxwidgets instead of deprecated wxmac
==> ./configure --prefix=/opt/homebrew/Cellar/survex/1.2.43 --bindir=/opt/homebr
==> make
Last 15 lines from /Users/pawczak/Library/Logs/Homebrew/survex/02.make:
#include <proj_api.h>
         ^~~~~~~~~~~~
make[3]: *** [netskel.o] Error 1
make[3]: *** [commands.o] Error 1
1 error generated.
1 error generated.
1 error generated.
mv -f .deps/date.Tpo .deps/date.Po
make[3]: *** [datain.o] Error 1
make[3]: *** [listpos.o] Error 1
make[3]: *** [cavern.o] Error 1
mv -f .deps/img_hosted.Tpo .deps/img_hosted.Po
make[2]: *** [all] Error 2
make[1]: *** [all-recursive] Error 1
make: *** [all] Error 2

If reporting this issue please do so to (not Homebrew/brew or Homebrew/core):
  survex/survex

/opt/homebrew/Library/Homebrew/utils/github/api.rb:304:in `raise_error': Validation Failed: [{"message"=>"The listed users and repositories cannot be searched either because the resources do not exist or you do not have permission to view them.", "resource"=>"Search", "field"=>"q", "code"=>"invalid"}] (GitHub::API::ValidationFailedError)
	from /opt/homebrew/Library/Homebrew/utils/github/api.rb:234:in `open_rest'
	from /opt/homebrew/Library/Homebrew/utils/github.rb:166:in `search'
	from /opt/homebrew/Library/Homebrew/utils/github.rb:34:in `search_issues'
	from /opt/homebrew/Library/Homebrew/utils/github.rb:67:in `issues_for_formula'
	from /opt/homebrew/Library/Homebrew/exceptions.rb:491:in `fetch_issues'
	from /opt/homebrew/Library/Homebrew/exceptions.rb:487:in `issues'
	from /opt/homebrew/Library/Homebrew/exceptions.rb:541:in `dump'
	from /opt/homebrew/Library/Homebrew/brew.rb:155:in `rescue in <main>'
	from /opt/homebrew/Library/Homebrew/brew.rb:143:in `<main>'
/opt/homebrew/Library/Homebrew/formula.rb:2309:in `block in system': Failed executing: make (BuildError)
	from /opt/homebrew/Library/Homebrew/formula.rb:2245:in `open'
	from /opt/homebrew/Library/Homebrew/formula.rb:2245:in `system'
	from /opt/homebrew/Library/Taps/survex/homebrew-survex/HomebrewFormula/survex.rb:21:in `install'
	from /opt/homebrew/Library/Homebrew/build.rb:172:in `block (3 levels) in install'
	from /opt/homebrew/Library/Homebrew/utils.rb:588:in `with_env'
	from /opt/homebrew/Library/Homebrew/build.rb:134:in `block (2 levels) in install'
	from /opt/homebrew/Library/Homebrew/formula.rb:1296:in `block in brew'
	from /opt/homebrew/Library/Homebrew/formula.rb:2475:in `block (2 levels) in stage'
	from /opt/homebrew/Library/Homebrew/utils.rb:588:in `with_env'
	from /opt/homebrew/Library/Homebrew/formula.rb:2474:in `block in stage'
	from /opt/homebrew/Library/Homebrew/resource.rb:126:in `block (2 levels) in unpack'
	from /opt/homebrew/Library/Homebrew/download_strategy.rb:115:in `chdir'
	from /opt/homebrew/Library/Homebrew/download_strategy.rb:115:in `chdir'
	from /opt/homebrew/Library/Homebrew/download_strategy.rb:102:in `stage'
	from /opt/homebrew/Library/Homebrew/resource.rb:122:in `block in unpack'
	from /opt/homebrew/Library/Homebrew/mktemp.rb:63:in `block in run'
	from /opt/homebrew/Library/Homebrew/mktemp.rb:63:in `chdir'
	from /opt/homebrew/Library/Homebrew/mktemp.rb:63:in `run'
	from /opt/homebrew/Library/Homebrew/resource.rb:208:in `mktemp'
	from /opt/homebrew/Library/Homebrew/resource.rb:121:in `unpack'
	from /opt/homebrew/Library/Homebrew/resource.rb:96:in `stage'
	from /System/Library/Frameworks/Ruby.framework/Versions/2.6/usr/lib/ruby/2.6.0/forwardable.rb:230:in `stage'
	from /opt/homebrew/Library/Homebrew/formula.rb:2454:in `stage'
	from /opt/homebrew/Library/Homebrew/formula.rb:1289:in `brew'
	from /opt/homebrew/Library/Homebrew/build.rb:129:in `block in install'
	from /opt/homebrew/Library/Homebrew/utils.rb:588:in `with_env'
	from /opt/homebrew/Library/Homebrew/build.rb:124:in `install'
	from /opt/homebrew/Library/Homebrew/build.rb:224:in `<main>'

comment:4 Changed 4 months ago by Olly Betts

==> Downloading https://survex.com/software/1.2.43/survex-1.2.43.tar.gz

That's not using the updated package - the updated package is 1.4.1.

I don't use or indeed totally understand homebrew, but I wonder if the problem is you already installed and need to use the steps given to update instead:

Once you've installed as above, you can upgrade your homebrew packages (including Survex) like so:

brew update brew upgrade

comment:5 Changed 4 months ago by Pawczak

I didn't realise i just need to update/upgrade and installation took proper package (1.4.1).

After successful installation i cannot open the app. It's opening without any windows showing and status is "App is not responding".

But the installation problem was resolved. Thank you very much.

comment:6 Changed 4 months ago by Pawczak

Resolution: fixed
Status: reopenedclosed

comment:7 Changed 3 months ago by Olly Betts

After successful installation i cannot open the app. It's opening without any windows showing and status is "App is not responding".

That's being tracked in #120. Apparently if you load a file it works, it's only starting aven without a file which fails (which isn't ideal and would be great to solve, but at least there's a reasonable workaround).

Note: See TracTickets for help on using tickets.