Opened 10 months ago

Last modified 2 months ago

#100 new defect

Aven crash Asus-Tablett W510 Intel Atom CPU Z2760 Windows 10 1607 Build 14393.2670

Reported by: milosch Owned by: Olly Betts
Priority: minor Milestone:
Component: aven Version:
Keywords: Cc:

Description

Aven crash file * .3d is generated. On other computers works flawlessly. On the computer comes "Aven.exe is not working anymore. The program ..."

Compatibility mode up to Windows XP does not help. Older versions of Survex, until 1.2.32 the same error. Aven used to work. Probably Windows :~

Attachments (2)

Report.wer (10.3 KB) - added by milosch 10 months ago.
Survex_Probleme.txt (6.5 KB) - added by milosch 10 months ago.

Download all attachments as: .zip

Change History (7)

Changed 10 months ago by milosch

Attachment: Report.wer added

Changed 10 months ago by milosch

Attachment: Survex_Probleme.txt added

comment:1 Changed 10 months ago by Olly Betts

Older versions of Survex, until 1.2.32 the same error. Aven used to work

So you're saying that 1.2.32 worked OK but 1.2.33 doesn't?

Or that 1.2.31 worked OK but 1.2.32 doesn't?

Or something else?

Knowing exactly when this stopped working would likely help a lot in understanding what's going on.

comment:2 Changed 4 months ago by Olly Betts

I'd guess maybe something is trying to use a CPU instruction which isn't supported on the machine where this fails - this seems to be a CPU from ~2012 and Atom CPUs were cut down low power models. If my guess is right and we can work out what's generating this instruction, we can hopefully adjust things to stop that happening.

But without clarifying which versions are affected, it's hard for me to look into this further. The attachments don't seem to contain anything to tell me where the crash happens.

comment:3 Changed 4 months ago by Olly Betts

Milestone: 1.2.37

Ticket retargeted after milestone closed

comment:4 Changed 2 months ago by mteg

I'm currently on expedition with Milosch in Austria. The crash occurs on loading a 3D file into aven, probably on initialization of the OpenGL canvas (the survey tree loads and then immediately a message box informs that the program "has to be closed"). We checked old Survex versions until 1.2.32 and also 1.2.10 and all of them crash on this old but very convenient tablet. Sad thing is it used to work alright on this very hardware and probably got broken with one of the Windows updates. It is now hard to tell when it actually stopped working, since the tablet is only used on expeditions.

comment:5 Changed 2 months ago by Olly Betts

If an old version of Aven used to work and the same version now doesn't, that does rather suggest the problem is external to Survex and there's probably not much we can do.

While trying to check what the CPU requirements actually are, I found this which might be useful:

https://answers.microsoft.com/en-us/windows/forum/all/intel-atom-z2760-in-windows-10-opengl-workaround/9b6a0bb5-02ae-430b-a020-982f94b67af2

If you can't resolve this and don't require the tablet to run anything that requires a particular OS, you could try installing Linux on it, which generally has good support for older hardware. Certainly worth a try if the tablet is otherwise junk.

Note: See TracTickets for help on using tickets.