source: git/debian/rules @ 839db8b

RELEASE/1.1RELEASE/1.2debug-cidebug-ci-sanitisersstereowalls-data
Last change on this file since 839db8b was 839db8b, checked in by Olly Betts <olly@…>, 18 years ago

Sort out installation and packaging of vim files.

git-svn-id: file:///home/survex-svn/survex/branches/survex-1_1@3256 4b37db11-9a0c-4f06-9ece-9ab7cdaee568

  • Property mode set to 100755
File size: 2.9 KB
Line 
1#!/usr/bin/make -f
2# Based on public domain debhelper example rules.multi2 by Joey Hess.
3#
4# Copyright (C) 2005,2006 Olly Betts
5#
6# GPL licensed.
7#
8# This is a multibinary package.  You can build any of the binary packages
9# independently by using the appropriate binary-<package> target.
10
11# Uncomment this to turn on verbose mode.
12#export DH_VERBOSE=1
13
14# This has to be exported to make some magic below work.
15export DH_OPTIONS
16
17ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
18CFLAGS += -O0
19CXXFLAGS += -O0
20else
21CFLAGS += -O2
22CXXFLAGS += -O2
23endif
24ifneq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
25STRIP=/bin/true
26endif
27
28# Make sure DEB_BUILD_GNU_TYPE and DEB_HOST_GNU_TYPE are set even if
29# we aren't called from dpkg-buildpackage, but don't reset them if
30# they're already set so the caller can override dpkg-architecture.
31export DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
32export DEB_HOST_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
33
34build: build-stamp
35build-stamp:
36        dh_testdir
37
38        ./configure --build $(DEB_BUILD_GNU_TYPE) --host $(DEB_HOST_GNU_TYPE) --prefix=/usr --mandir=\$${prefix}/share/man --enable-docdir=\$${prefix}/share/doc/survex CFLAGS=$(CFLAGS) CXXFLAGS=$(CXXFLAGS) STRIP=$(STRIP)
39        $(MAKE)
40ifeq    ($(DEB_HOST_GNU_TYPE),$(DEB_BUILD_GNU_TYPE))
41        $(MAKE) check
42endif
43        touch build-stamp
44
45clean:
46        dh_testdir
47        dh_testroot
48        rm -f build-stamp
49
50        -$(MAKE) distclean
51
52        dh_clean
53
54install: DH_OPTIONS=
55install: build
56        dh_testdir
57        dh_testroot
58        dh_clean -k
59        dh_installdirs
60
61        $(MAKE) DESTDIR=`pwd`/debian/tmp install
62        $(MAKE) -C vim DESTDIR=`pwd`/debian/tmp vimdir=/usr/share/vim/addons install
63
64        dh_install --fail-missing
65
66# This single target is used to build all the packages, all at once, or
67# one at a time. So keep in mind: any options passed to commands here will
68# affect _all_ packages. Anything you want to only affect one package
69# should be put in another target, such as the install target.
70binary-common:
71# Avoid warning:
72# dpkg-gencontrol: warning: unknown substitution variable ${misc:Depends}
73        echo 'misc:Depends=' > debian/survex.substvars
74        dh_testdir
75        dh_testroot
76        dh_installchangelogs
77        dh_installdocs
78        dh_installexamples
79        dh_installmenu
80# FIXME: investigate using dh_installmime
81#       dh_installmime
82        dh_strip
83        dh_link
84        dh_compress
85        dh_fixperms
86        dh_installdeb
87        dh_shlibdeps
88        dh_gencontrol
89        dh_md5sums
90        dh_builddeb
91
92# Build architecture independent packages using the common target.
93binary-indep: build install
94        $(MAKE) -f debian/rules DH_OPTIONS=-i binary-common
95
96# Build architecture dependant packages using the common target.
97binary-arch: build install
98        $(MAKE) -f debian/rules DH_OPTIONS=-a binary-common
99
100# Any other binary targets build just one binary package at a time.
101binary-%: build install
102        make -f debian/rules binary-common DH_OPTIONS=-p$*
103
104binary: binary-indep binary-arch
105.PHONY: build clean binary-indep binary-arch binary-common binary install
Note: See TracBrowser for help on using the repository browser.