source: git/debian/rules @ 105831f

RELEASE/1.1RELEASE/1.2debug-cidebug-ci-sanitisersfaster-cavernlogstereowalls-datawalls-data-hanging-as-warning
Last change on this file since 105831f was 1e5baa1, checked in by Olly Betts <olly@…>, 18 years ago

Avoid misc:Depends warning

git-svn-id: file:///home/survex-svn/survex/branches/survex-1_1@3247 4b37db11-9a0c-4f06-9ece-9ab7cdaee568

  • Property mode set to 100755
File size: 3.0 KB
RevLine 
[70d428e]1#!/usr/bin/make -f
[a061c14a]2# Based on public domain debhelper example rules.multi2 by Joey Hess.
[b462168]3#
[a061c14a]4# Copyright (C) 2005,2006 Olly Betts
[70d428e]5#
[a061c14a]6# GPL licensed.
7#
8# This is a multibinary package.  You can build any of the binary packages
9# independently by using the appropriate binary-<package> target.
[70d428e]10
11# Uncomment this to turn on verbose mode.
12#export DH_VERBOSE=1
13
14# This has to be exported to make some magic below work.
15export DH_OPTIONS
16
[b462168]17ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
18CFLAGS += -O0
[a061c14a]19CXXFLAGS += -O0
[b462168]20else
21CFLAGS += -O2
[a061c14a]22CXXFLAGS += -O2
[b462168]23endif
24ifneq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
[a061c14a]25STRIP=/bin/true
[b462168]26endif
27
[a061c14a]28# Make sure DEB_BUILD_GNU_TYPE and DEB_HOST_GNU_TYPE are set even if
29# we aren't called from dpkg-buildpackage, but don't reset them if
30# they're already set so the caller can override dpkg-architecture.
31export DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
32export DEB_HOST_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
33
[70d428e]34build: build-stamp
35build-stamp:
36        dh_testdir
37
[a061c14a]38        ./configure --build $(DEB_BUILD_GNU_TYPE) --host $(DEB_HOST_GNU_TYPE) --prefix=/usr --mandir=\$${prefix}/share/man --enable-docdir=\$${prefix}/share/doc/survex CFLAGS=$(CFLAGS) CXXFLAGS=$(CXXFLAGS) STRIP=$(STRIP)
[70d428e]39        $(MAKE)
[7ad2d31]40ifeq    ($(DEB_HOST_GNU_TYPE),$(DEB_BUILD_GNU_TYPE))
[50eb45d]41        $(MAKE) check
[7ad2d31]42endif
[70d428e]43        touch build-stamp
44
45clean:
46        dh_testdir
47        dh_testroot
48        rm -f build-stamp
49
50        -$(MAKE) distclean
51
52        dh_clean
53
54install: DH_OPTIONS=
55install: build
56        dh_testdir
57        dh_testroot
58        dh_clean -k
59        dh_installdirs
60
[a061c14a]61        $(MAKE) DESTDIR=`pwd`/debian/tmp install
62        install -d debian/survex/usr/share/vim/addons/ftdetect
63        install -d debian/survex/usr/share/vim/addons/syntax
64        install -m 0644 vim/ftdetect/survex.vim debian/survex/usr/share/vim/addons/ftdetect
65        install -m 0644 vim/syntax/survex.vim debian/survex/usr/share/vim/addons/syntax
[70d428e]66
[a061c14a]67        dh_install --fail-missing
[70d428e]68
69# This single target is used to build all the packages, all at once, or
70# one at a time. So keep in mind: any options passed to commands here will
71# affect _all_ packages. Anything you want to only affect one package
72# should be put in another target, such as the install target.
[a061c14a]73binary-common:
[1e5baa1]74# Avoid warning:
75# dpkg-gencontrol: warning: unknown substitution variable ${misc:Depends}
76        echo 'misc:Depends=' > debian/survex.substvars
[70d428e]77        dh_testdir
78        dh_testroot
[a061c14a]79        dh_installchangelogs
[70d428e]80        dh_installdocs
81        dh_installexamples
82        dh_installmenu
[a061c14a]83# FIXME: investigate using dh_installmime
[70d428e]84#       dh_installmime
85        dh_strip
[a061c14a]86        dh_link
[70d428e]87        dh_compress
88        dh_fixperms
89        dh_installdeb
90        dh_shlibdeps
91        dh_gencontrol
92        dh_md5sums
93        dh_builddeb
94
[a061c14a]95# Build architecture independent packages using the common target.
96binary-indep: build install
[34c131f]97        $(MAKE) -f debian/rules DH_OPTIONS=-i binary-common
[70d428e]98
99# Build architecture dependant packages using the common target.
[a061c14a]100binary-arch: build install
[70d428e]101        $(MAKE) -f debian/rules DH_OPTIONS=-a binary-common
102
103# Any other binary targets build just one binary package at a time.
104binary-%: build install
105        make -f debian/rules binary-common DH_OPTIONS=-p$*
106
[a061c14a]107binary: binary-indep binary-arch
108.PHONY: build clean binary-indep binary-arch binary-common binary install
Note: See TracBrowser for help on using the repository browser.