Changeset 9c0b089 in git


Ignore:
Timestamp:
09/07/10 15:43:16 (9 years ago)
Author:
Olly Betts <olly@…>
Branches:
add-show-splays, line_contents, master, stereo, svn/github/master, svn/origin/master, svn/tags/1.1.14, svn/tags/1.1.15, svn/tags/1.1.16, svn/tags/1.2.0, svn/tags/1.2.1, svn/tags/1.2.2, svn/tags/1.2.3, svn/tags/1.2.4, svn/tags/1.2.5, svn/trunk, travis-osx
Children:
a75f5a1
Parents:
72f1bb2
Message:

configure.in: Link aven with -lGLU which SuSE Linux needs.

git-svn-id: file:///home/survex-svn/survex/trunk@3478 4b37db11-9a0c-4f06-9ece-9ab7cdaee568

Files:
2 edited

Legend:

Unmodified
Added
Removed
  • ChangeLog

    r72f1bb2 r9c0b089  
     1Fri Jul 09 14:42:47 GMT 2010  Olly Betts <olly@survex.com>
     2
     3        * configure.in: Link aven with -lGLU which SuSE Linux needs.
     4
    15Fri Jul 09 14:31:39 GMT 2010  Olly Betts <olly@survex.com>
    26
  • configure.in

    r72f1bb2 r9c0b089  
    192192dnl Needed for nvidia drivers on linux (for some setups anyway).
    193193AC_CHECK_LIB(Xxf86vm, XF86VidModeQueryVersion, [WX_LIBS="$WX_LIBS -lXxf86vm"], [], [$WX_LIBS])
     194dnl SuSE Linux needs -lGLU explicitly, and we do use functions from it directly
     195dnl so always link it.
     196AC_CHECK_LIB([GLU], [gluProject], [WX_LIBS="$WX_LIBS -lGLU"], [], [$WX_LIBS])
    194197AC_SUBST(WX_LIBS)
     198
    195199dnl Older wx-config didn't support --ldflags (2.6.3 doesn't) - error goes to
    196200dnl stderr, with nothing to stdout, so just ignore stderr.
Note: See TracChangeset for help on using the changeset viewer.