Changeset 148c993 in git


Ignore:
Timestamp:
04/09/19 04:19:32 (2 weeks ago)
Author:
Olly Betts <olly@…>
Branches:
master
Children:
64a9dc6
Parents:
040c02e
Message:

Don't error out on new GCC9 warnings

The wx headers currently trigger two new GCC9 warnings. The wx
developers are aware of this, but it's not yet been addressed.

File:
1 edited

Legend:

Unmodified
Added
Removed
  • make_release

    r040c02e r148c993  
    3636  mv INSTALL.keep INSTALL
    3737  ./configure CC=gcc CXX=g++
    38   # Don't error out on new GCC8 warning for now.
    39   make CFLAGS='-Werror' CXXFLAGS='-Werror -Wno-error=cast-function-type'
     38  # Don't error out on new GCC8 and GCC9 warnings for now.
     39  make CFLAGS='-Werror' CXXFLAGS='-Werror -Wno-error=cast-function-type -Wno-error=deprecated-copy -Wno-error=ignored-qualifiers'
    4040  VALGRIND=valgrind make distcheck VERBOSE=1
    4141else
Note: See TracChangeset for help on using the changeset viewer.